3.1.2. Testing the project results
The network is configured and needs to be tested. If computers are possible on their own VLAN boundaries, but computers from different VLANs are not, the result is considered positive (Fig. 5).
Figure 5. Ping to PC3 and PC4 from PC1
We have all five computers on the same 10.0.0.0/8 network, but on different virtual networks.
Table 1.
Variants for performing practical work
Variant
|
Ports
|
The numbers of VLANs
|
Network Devices
|
|
Access
|
3
|
8 computers, 1 switch
|
|
Access
|
4
|
5 computers, 1 switch
|
|
Access
|
3
|
6 computers, 1 switch
|
|
Access
|
4
|
7 computers, 1 switch
|
|
Access
|
3
|
8 computers, 1 switch
|
|
Access
|
4
|
5 computers, 1 switch
|
|
Access
|
3
|
6 computers, 1 switch
|
|
Access
|
4
|
7 computers, 1 switch
|
|
Access
|
3
|
6 computers, 1 switch
|
|
Access
|
4
|
5 computers, 1 switch
|
|
Access
|
3
|
4 computers, 1 switch
|
|
Access
|
4
|
6 computers, 1 switch
|
|
Access
|
3
|
7 computers, 1 switch
|
|
Access, trunk
|
2
|
8 computers, 2 switches
|
|
Access, trunk
|
3
|
7 computers, 2 switches
|
|
Access, trunk
|
2
|
5 computers, 2 switches
|
|
Access, trunk
|
3
|
5 computers, 2 switches
|
|
Access, trunk
|
2
|
6 computers, 2 switches
|
|
Access, trunk
|
3
|
5 computers, 2 switches
|
|
Access, trunk
|
2
|
4 computers, 2 switches
|
|
Access, trunk
|
3
|
8 computers, 2 switches
|
|
Access, trunk
|
2
|
7 computers, 2 switches
|
|
Access, trunk
|
3
|
6 computers, 2 switches
|
|
Access, trunk
|
2
|
8 computers, 2 switches
|
|
Access, trunk
|
3
|
8 computers, 2 switches
|
3.2. Also, in this practical work, the following task should be done:
1. Building a network according to Figure 6.
2. Configuring basic parameters of VTP.
3. Adding VLANs.
4. Determining whether ports belong to VLANs.
5. Identification of trunks.
6. Configure routing between VLANs.
Figure 6. A network scheme divided into VLANs
3.2.1. Configuring a VTP-domain switch
First of all, you need to configure VTP basic parameters and add VLANs. Then determine whether the ports belong to the VLAN and identify the trunk. Next, you need to set up routing between VLANs.
3.2.1.1. Setting the switch Sw0
Sw0>enable
Sw0#configure terminal
1. Configure basic VTP parameters
Sw0(config)#vtp mode server
Sw0(config)#vtp domain CCNA
Sw0(config)#vtp password 12345
Sw0(config)#vtp version 2
2. Add VLANs
Sw0(config)#vlan 20
Sw0(config-vlan)#name RED
Sw0(config-vlan)#exit
Sw0(config)#vlan 30
Sw0(config-vlan)#name GREEN
Sw0(config-vlan)#exit
Sw0(config)#vlan 40
Sw0(config-vlan)#name BLUE
Sw0(config-vlan)#exit
3. Identification of trunks
Sw0(config)#interface range FastEthernet 0/1-5
Sw0(config-if-range)#switchport mode trunk
Sw0(config-if-range)#end
Sw0#copy run start
3.2.1.2. Setting the switch Sw1
Sw1>enable
Sw1#configure terminal
1. Configure basic VTP parameters
Sw1(config)#vtp mode client
Sw0(config)#vtp domain CCNA
Sw0(config)#vtp password 12345
2. Add VLANs
Sw1(config)#interface FastEthernet 0/2
Sw1(config-if)#switchport mode access
Sw1(config-if)#switchport access vlan 20
Sw1(config-if)#exit
Sw1(config)#interface FastEthernet 0/3
Sw1(config-if)#switchport mode access
Sw1(config-if)#switchport access vlan 30
Sw1(config-if)#exit
Sw1(config)#interface FastEthernet 0/4
Sw1(config-if)#switchport mode access
Sw1(config-if)#switchport access vlan 40
Sw1(config-if)#exit
3. Identification of trunks
Sw1(config)#interface FastEthernet 0/1
Sw1(config-if)#switchport mode trunk
Sw1(config-if)#end
Sw1#copy run start
3.2.1.3. Setting the switch Sw2
Sw2>enable
Sw2#configure terminal
1. Configure basic VTP parameters
Sw2(config)#vtp mode client
Sw0(config)#vtp domain CCNA
Sw0(config)#vtp password 12345
2. Add VLANs
Sw2(config)#interface FastEthernet 0/2
Sw2(config-if)#switchport mode access
Sw2(config-if)#switchport access vlan 20
Sw2(config-if)#exit
Sw2(config)#interface FastEthernet 0/3
Sw2(config-if)#switchport mode access
Sw2(config-if)#switchport access vlan 30
Sw2(config-if)#exit
Sw2(config)#interface FastEthernet 0/4
Sw2(config-if)#switchport mode access
Sw2(config-if)#switchport access vlan 40
Sw2(config-if)#exit
3. Identification of trunks
Sw2(config)#interface FastEthernet 0/1
Sw2(config-if)#switchport mode trunk
Sw2(config-if)#end
Sw2#copy run start
3.2.1.4. Setting the switch Sw3
Sw3>enable
Sw3#configure terminal
1. Configure basic VTP parameters
Sw3(config)#vtp mode client
Sw0(config)#vtp domain CCNA
Sw0(config)#vtp password 12345
2. Add VLANs
Sw3(config)#interface FastEthernet 0/2
Sw3(config-if)#switchport mode access
Sw3(config-if)#switchport access vlan 20
Sw3(config-if)#exit
Sw3(config)#interface FastEthernet 0/3
Sw3(config-if)#switchport mode access
Sw3(config-if)#switchport access vlan 30
Sw3(config-if)#exit
Sw3(config)#interface FastEthernet 0/4
Sw3(config-if)#switchport mode access
Sw3(config-if)#switchport access vlan 40
Sw3(config-if)#exit
3. Identification of trunks
Sw3(config)#interface FastEthernet 0/1
Sw3(config-if)#switchport mode trunk
Sw3(config-if)#end
Sw2#copy run start
3.2.1.5. Setting the switch Sw4
Sw3>enable
Sw3#configure terminal
1. Configure basic VTP parameters
Sw3(config)#vtp mode client
Sw0(config)#vtp domain CCNA
Sw0(config)#vtp password 12345
2. Add VLANs
Sw4(config)#interface FastEthernet 0/2
Sw4(config-if)#switchport mode access
Sw4(config-if)#switchport access vlan 20
Sw4(config-if)#exit
Sw4(config)#interface FastEthernet 0/3
Sw4(config-if)#switchport mode access
Sw4(config-if)#switchport access vlan 30
Sw4(config-if)#exit
Sw4(config)#interface FastEthernet 0/4
Sw4(config-if)#switchport mode access
Sw4(config-if)#switchport access vlan 40
Sw4(config-if)#exit
3. Identification of trunks
Sw4(config)#interface FastEthernet 0/1
Sw4(config-if)#switchport mode trunk
Sw4(config-if)#end
Sw4#copy run start
3.2.2. Configure router R1
1. Configure routing between VLANs
R1>enableRouter#configure terminal
R1(config)#interface FastEthernet 0/0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface FastEthernet 0/0.20
R1(config-subif)#encapsulation dot1Q 20
R1(config-subif)#ip address 192.168.20.1 255.255.255.0
R1(config-subif)#exit
R1(config)#interface FastEthernet 0/0.30
R1(config-subif)#encapsulation dot1Q 30
R1(config-subif)#ip address 192.168.30.1 255.255.255.0
R1(config-subif)#exit
R1(config)#interface FastEthernet 0/0.40
R1(config-subif)#encapsulation dot1Q 40
R1(config-subif)#ip address 192.168.40.1 255.255.255.0
R1(config-subif)#end
R1#copy run start
2. Diagnosis of VTP
R1#show vtp status
R1#show vlan
R1#show interfaces trunk
3.2.3. Testing the process of practical work
On PC21, do the following:
ping 192.168.20.1 - default gw
ping 192.168.20.22 - PC22
ping 192.168.20.23 - PC23
ping 192.168.20.24 - PC24
ping 192.168.30.31 - PC31
ping 192.168.30.32 - PC32
ping 192.168.30.33 - PC33
ping 192.168.40.41 - PC41
ping 192.168.40.42 - PC42
ping 192.168.40.43 - PC43
ping 192.168.40.44 - PC44
4. Content of the report
The report should include the following:
– Name and purpose of work.
– “screen shots” showing the completion of work.
– The result of the work.
– Short answers to control questions.
5. Control questions
1. Describe the principle of operation of VLAN.
2. List the advantages of VLAN.
3. Tell the difference between access and trunk ports.
4. Which commands are used to configure VLAN?
5. Describe the principle of operation of the VTP protocol.
6. How does the VTP protocol work?
7. What is the sequence of actions to configure the VTP protocol?
8. How to check work results?
Dostları ilə paylaş: |